http://www.perlmonks.org?node_id=1083933


in reply to Re: LWP and HTTPS
in thread LWP and HTTPS

But why it's working in the browser? How I can tell LWP to ignore this error?

Replies are listed 'Best First'.
Re^3: LWP and HTTPS
by noxxi (Pilgrim) on Apr 26, 2014 at 20:48 UTC
    Yet another broken SSL server which cannot do TLS1.0 or better. Browsers work around this kind of error by retrying with a downgraded SSL version.
    Recent versions of LWP (base of WWW::Mechanize) use IO::Socket::SSL/Net::SSLeay by default and you can simply enforce a specific SSL version like this:
    $mech->ssl_opts( SSL_version => 'SSLv3');
    I've tested it and it works with this broken server.
      Brilliant!!! Thank you! But I still don't understand why $ENV{ HTTPS_VERSION }= 3 is not work but  SSL_version => 'SSLv3' works...
        HTTPS_VERSION is a feature of Net::SSL/Crypt::SSLeay only, but with newer LWP Net::HTTPS/IO::Socket::SSL/Net::SSLeay is used instead.
Re^3: LWP and HTTPS
by Gangabass (Vicar) on Apr 26, 2014 at 13:37 UTC