http://www.perlmonks.org?node_id=1079261


in reply to JSON 2.5 2.90

What do you get from the following:

perl -e"use JSON; JSON->VERSION(2.5);"

(A failure in that code is what leads to the error you get.)

Replies are listed 'Best First'.
Re^2: JSON 2.5 2.90
by pno (Initiate) on Mar 24, 2014 at 07:43 UTC
    perl.exe -e "use JSON; JSON->VERSION(2.5);" Can't locate JSON/XS.pm in @INC (you may need to install the JSON::XS +module) (@INC contains: c:/Software/Perl5.18/site/lib c:/Software/Per +l5.18/lib .) at (eval 4) line 2. BEGIN failed--compilation aborted at (eval 4) line 2. at -e line 1. Compilation failed in require at -e line 1. BEGIN failed--compilation aborted at -e line 1.
      You are explicitly requesting that JSON uses JSON::XS instead of JSON::PP (by setting env var PERL_JSON_BACKEND to JSON::XS), but you don't have JSON::XS installed.