http://www.perlmonks.org?node_id=171327

venki has asked for the wisdom of the Perl Monks concerning the following question:

Hi all, After searching the perlmonks i was not able to get the specific answer. So i am posing my question. I have recently installed perl 5.6.1 CGI.pm-2.81 DBI-1.22 When i try to install DBD-Oracle-1.12 i get into errors *** Error code 1 make: Fatal error: Command failed for target `Oracle.o' I have oracle client 9.2 on my system. I would like to know whether the version i am using to install DBD is correct or not. Also may i know what exatly i need to follow when i install this modules. Also any tips specifically should be followed. I appreciate your helps guys. Thanks

Replies are listed 'Best First'.
Re: DBD Module
by dws (Chancellor) on Jun 03, 2002 at 20:51 UTC
    Also may i know what exatly i need to follow when i install this modules.

    You don't mention what platform you're on. If you're on Win32, you can install using ActiveState's Perl Package Manager (ppm). The incantation is   c:> ppm install dbd-oracle But since the error message you got is from make(1), chances are you're on a *nix platform. Is there any chance you're on one that doesn't have a C development environment installed?


    Update: Beatnik points out that Oracle.o implies *nix. D'oh.

      Its UNIX platform. i have installed c compiler. do i need more than that? If yes what else and where can i get it.
        -- for you!

        If you would kindly supply us with the last 15 or 20 lines of make output, we could see what is going wrong, and if you need some extra.

        This way, we cannot help you... It is like calling a helpdesk and stating that your computer doesn't work, but refusing to tell what exactly doesn't work, or if you have even plugged in the powercord yet.

        So please enlighten us with your output...

        er formait hyarya.
        -- "Life is a house and the next tornado is never far away"
        -- "lovely by nature"

Re: DBD Module
by Sinister (Friar) on Jun 03, 2002 at 20:48 UTC
    To me this seems as more a dependancy problem of some other form, then a wrong oracle version.

    make probably said more then that, just above. Could you post, say the last 15 lines of make output, this could help (btw: put them between <code></code> tags for humanreadability)

    er formait hyarya.
    -- "Life is a house and the next tornado is never far away"
    -- "lovely by nature"

Re: DBD Module
by Joost (Canon) on Jun 04, 2002 at 14:25 UTC
    Also may i know what exatly i need to follow when i install this modules

    You need an Oracle client installation on your machine.

    On most systems with CPAN installed, you can then do

    perl -MCPAN -e'install DBD::Oracle';
    Otherwise, unzip the tarball and do
    perl Makefile.PL make make test make install
    As usual. Then you will also be reminded that your really should read the README for specific details.

    Update: it might help to know which UNIX variant and which C compiler you are using.

    -- Joost downtime n. The period during which a system is error-free and immune from user input.