in reply to Failure trying to build Imager::File::PNG

"-lpng" always means "libpng.%ext" on unix/linux where %ext depends on the platform. However, on Linux, as far as I can tell, that's always .so, so look for a package that provides /usr/lib/libpng.so or /lib/libpng.so. On Gentoo, that's the libpng ebuild with a URL of http://www.libpng.org. Hope that helps.

Also your test code failed with an inability to include "png.h" so there's another file to look for from your libpng package - /usr/include/png.h.

Good luck - it built fine here :-)

  • Comment on Re: Failure trying to build Imager::File::PNG

Replies are listed 'Best First'.
Re^2: Failure trying to build Imager::File::PNG
by GrandFather (Saint) on Nov 14, 2012 at 04:54 UTC

    Thanks! That was the hint I needed.

    apt-get install libpng12-dev

    did the magic for me. Mind you, it took three tries before I found the right package!

    True laziness is hard work