in reply to Re: perl 5.6.0-5.6.1 upgrade problem
in thread perl 5.6.0-5.6.1 upgrade problem

Hi,
I'm pretty sure the scripts are pointing to the right perl binaries:
# head -n 8 /usr/apache/htdocs/mrbs/badpw.pl
#!/usr/bin/perl

# $Id: badpw.pl,v 1.3 2001/02/25 01:34:20 lbayuk Exp $

# Read AUTHENTICATION for more information
# about this script

use strict;

and:

# ls -asl /usr/bin/perl
1840 -rwxr-xr-x   3 root     other     927784 Aug  6 16:53 /usr/bin/perl
# /usr/bin/perl -v

This is perl, v5.6.1 built for sun4-solaris

Copyright 1987-2001, Larry Wall


:(
dan
  • Comment on Re: Re: perl 5.6.0-5.6.1 upgrade problem

Replies are listed 'Best First'.
Re: Re: Re: perl 5.6.0-5.6.1 upgrade problem
by physi (Friar) on Aug 07, 2001 at 17:40 UTC
    Funny, above you wrote your INC contains /usr/local/lib ...
    are you sure you have to use /usr/bin/perl and not /usr/local/bin/perl ?
    ----------------------------------- --the good, the bad and the physi-- -----------------------------------
      I already checked everywhere I know the perl binaries to be after the update. It was clear when I upgraded perl would be placed in /usr/local/bin/perl and /usr/bin/perl.
      Changing the call to the binary in the script does not fix the error I'm afraid, only commenting out 'use strict' does. And being a good boy I always use strict! Damn. Thanks for the suggestion though!
      dan