in reply to where is Net::SSH::perl module for Win32 perl

There isn't a specific distribution of Net::SSH::Perl for Win32. Net::SSH::Perl itself is pure Perl; some of the libraries that it relies upon do require compilation. In particular, the big integer libraries: SSH-1 requires Math::GMP, SSH-2 requires Math::Pari. You don't need to install support for both SSH-1 and SSH-2 unless you plan to use both protocols.

I would love it if someone created a PPM for Math::Pari or Math::GMP, but currently no such creature exists.

A list of the prerequisite modules for the two different protocols are listed in the README.

  • Comment on Re: where is Net::SSH::perl module for Win32 perl