in reply to Re^3: Perl module need regular maintenance. They are not functioning as desired to be.
in thread Perl module need regular maintenance. They are not functioning as desired to be.

Thanks for suggestions. I'll try in my Windows machine. Meanwhile, I've another Windows machine and trying to install Perl Module Net::Packet. Getting this errors. I've manually downloaded all tar files (Socket6-0.25, Net-Libdnet-0.98, Net-Packet-3.27). Please let me know how to get successfully install Net::Packet and get my developement environment ready.
C:\Perl\site\bin\dmake.exe test -- NOT OK
-----------------
UMEMOTO/Socket6-0.25.tar.gz Won't repeat unsuccessful test during this command
-----------------
Warning: Prerequisite 'Socket6 => 0' for 'GOMOR/Net-Write-1.07.tar.gz' + failed when processing 'UMEMOTO/Socket6 -0.25.tar.gz' with 'make_test => NO'. Continuing, but chances to succe +ed are limited.
-----------------
one dependency not OK (Socket6); additionally test harness failed C:\Perl\site\bin\dmake.exe test -- NOT OK
-----------------
C:\Perl\site\bin\dmake.exe -- NOT OK
-----------------
Warning: Prerequisite 'Socket6 => 0' for 'GOMOR/Net-Packet-3.27.tar.gz +' failed when processing 'UMEMOTO/Socket 6-0.25.tar.gz' with 'make_test => NO'. Continuing, but chances to succ +eed are limited. Warning: Prerequisite 'Net::Write => 1.00' for 'GOMOR/Net-Packet-3.27. +tar.gz' failed when processing 'GOMOR/Ne t-Write-1.07.tar.gz' with 'make_test => NO one dependency not OK (Sock +et6); additionally test harness failed'. Continuing, but chances to succeed are limited. Warning: Prerequisite 'Net::Libdnet => 0' for 'GOMOR/Net-Packet-3.27.t +ar.gz' failed when processing 'GOMOR/Net -Libdnet-0.98.tar.gz' with 'make => NO'. Continuing, but chances to su +cceed are limited.
-----------------
3 dependencies missing (Socket6,Net::Write,Net::Libdnet); additionally + test harness failed C:\Perl\site\bin\dmake.exe test -- NOT OK //hint// to see the cpan-testers results for installing this module, t +ry: reports GOMOR/Net-Packet-3.27.tar.gz Failed during this command: UMEMOTO/Socket6-0.25.tar.gz : make_test NO GOMOR/Net-Write-1.07.tar.gz : make_test NO one depen +dency not OK (Socket6); additionally tes t harness failed GOMOR/Net-Libdnet-0.98.tar.gz : make NO GOMOR/Net-Packet-3.27.tar.gz : make_test NO 3 depende +ncies missing (Socket6,Net::Write,Net::L ibdnet); additionally test harness failed
-----------------
  • Comment on Re^4: Perl module need regular maintenance. They are not functioning as desired to be.
  • Select or Download Code

Replies are listed 'Best First'.
Re^5: Perl module need regular maintenance. They are not functioning as desired to be.
by Corion (Pope) on Jul 22, 2014 at 06:31 UTC
    UMEMOTO/Socket6-0.25.tar.gz Won't repeat unsuccessful test during this command

    If this was the first module that failed, your next step is now to investigate why Socket6 fails on your machine. The bug tracker lists some of the problems people seem to encounter. To get a better view of what problems you have, enter the following command in the cpan client:

    look Socket6

    This opens a shell with everything unpacked for you so you can then run:

    dmake dmake test

    ... and see where it fails.