Mail::SpamCannibal's Makefile.PL attempts to extend the behaviour of ExtUtils::MakeMaker by messing with its internals, but some of those internals have changed.

For example, the warnings are normal, but it attempts to silence them. However, the way in which it does that doesn't work since ExtUtils-MakeMaker-6.44 (Feb 28, 2008).

I don't know if the other problems are related to this hackery. Your best bet would be to install an old version of ExtUtils::MakeMaker:

tar xvzf ExtUtils-MakeMaker-$OLDVER.tar.gz cd ExtUtils-MakeMaker-$OLDVER perl Makefile.PL PREFIX=/tmp/oldMM LIB=/tmp/oldMM/lib/perl5 make test install export PERL5LIB=/tmp/oldMM/lib/perl5${PERL5LIB:+:$PERL5LIB} ...proceed to install Mail-SpamCannibal...

In reply to Re: ERROR: is not a known parameter in perl Makefile.PL by ikegami
in thread ERROR: is not a known parameter in perl Makefile.PL by fochi

Title:
Use:  <p> text here (a paragraph) </p>
and:  <code> code here </code>
to format your post; it's "PerlMonks-approved HTML":