in reply to Trouble installing DBD::Pg

I think I can demystify this some. DBD::Pg gets compiled against a specific version of DBI. If you compile it against one version, but try to use it with a different version, you might get this error.

If you are installing DBD::Pg manually, it will tell you which version of DBI it is being compiled against. If it is not choosing the version you want, you can explicitly set PERL5LIB so that the version you want is found first. (Perhaps it is finding a global version of DBI, but you want to use a private use version of DBI).

Finding the global DBI:

$ perl Makefile.PL
 Using DBI 1.604 (for perl 5.008002 on i386-freebsd) installed in /usr/local/lib/perl5/site_perl/5.8.2/mach/auto/DBI/
Finding a local DBI:
$ PERL5LIB=/home/sap/betasite/perllib perl Makefile.PL
 Using DBI 1.616 (for perl 5.008002 on i386-freebsd) installed in /home/sap/betasite/perllib/i386-freebsd/auto/DBI/