in reply to Tie and Tie::Handle

Are you sure you have Tie::Handle version 3.0? What you get from CPAN is likely version 4. See the COMPATIBILITY section of the perldoc for Tie::Handle for more information.

Russ
Brainbench 'Most Valuable Professional' for Perl