Not that it has anything to do with jacque's problem, but what specifically do you disagree with? That my ($hash) = @_; shouldn't be spelled differently at all, or the way I chose to spell it? The only way I can see to improve the readability would have been to say my $hash = shift @_;
Update: Ok, after hearing several arguments in the CB along with jZed's reply, I am convinced that it is not necessarily better to write it that way. I doubt I will change how I write my code but I won't think it is deficient when others do.