http://www.perlmonks.org?node_id=11103790


in reply to Re: Using a base module with a required version
in thread Using a base module with a required version

Saying it this way

use Juliet 1.1; our @ISA = 'Juliet';
actually makes the most sense to me -- but I'm uneasy about twiddling with @ISA since that's how Perl gets told about inheritance.

Hiding @ISA with your middle example

use Juliet 1.1; use parent 'Juliet';
is less alarming -- but it seems like it does the same thing.

Alex / talexb / Toronto

Thanks PJ. We owe you so much. Groklaw -- RIP -- 2003 to 2013.

Replies are listed 'Best First'.
Re^3: Using a base module with a required version
by ikegami (Pope) on Aug 03, 2019 at 04:25 UTC

    I'm uneasy about twiddling with @ISA since that's how Perl gets told about inheritance.

    I've very confused. Isn't that exactly what you want to do?

    If not, you shouldn't be using base.pm or parent.pm or @ISA, just use Juliet 1.1;.