http://www.perlmonks.org?node_id=1213387


in reply to shebang anomaly

I feel your pain with the changes that Apple has brought about as part of High Sierra.

Almost like you, I routinely use the #!/usr/bin/env perl in my perl code. I differ in that I almost never use the command line switch(es) on it since the warnings pragma was introduced with perl 5.6. I recognize that the scoping behavior is different between the two and will occasionally use the -w when testing new modules that I haven't used before to see if something amiss may exist. And, I pretty much always type perl -d ... when I want the debugger or more often just hit the up arrow key to recall the command from my history.

Maybe this approach will be useful to you.

Also, while I am not a heavy user of PDL, I did recently install PDL and PDL::Graphics::Gnuplot in a perlbrewed perl 5.22.3 and don't remember having any problems installing it. I was setting up a new perl 5.26.2 this weekend when I saw your post. I went ahead and installed both on it. PDL installed and passed all test. PDL::Graphics::Gnuplot failed one test out 185.

# Failed test 'Setting empty plot title sets an empty title' # at t/plot.t line 862.

I am running 10.13.4. I also am an avid user of Homebrew and my success may be that I have packages installed from it that are used instead of the native packages from Apple. As a general rule, I do not use the Apple perl and only use Xcode for Apple specific work.

Cheers, lbe