http://www.perlmonks.org?node_id=948096


in reply to Re^2: In Need of Mentoring
in thread In Need of Mentoring

If you're inconsistent with lexical variables like my($fooBar, $quux_xyzzy), then that's fine by me. It may slightly confuse people hoping to delve into your code, but that's probably only a small number of people.

However, for public functions/methods - for the API you expect other people to code to - you should aim for consistency throughout a module or collection of related modules.

Generally speaking under_scores seem to be the most popular way of naming functions and methods, so unless you've got a specific reason to use another naming convention, should be the default option. Good reasons to use camelCase or runtogetherwords might be: