Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Re: Fedora 29 upgrade

by Paladin (Vicar)
on Aug 07, 2019 at 20:59 UTC ( #11104115=note: print w/replies, xml ) Need Help??


in reply to Fedora 29 upgrade

Fedora 28 came with Perl 5.26. Fedora 29 comes with Perl 5.28. The module (XML::Parser and any other XS modules) will need to be recompiled for the new version of Perl.

Replies are listed 'Best First'.
Re^2: Fedora 29 upgrade
by JRBJhawk (Novice) on Aug 07, 2019 at 22:01 UTC

    Thanks for the quick reply. When I tried to recompile (using the cpan command "install XML::Parser", I got:

    XML::Parser is up to date (2.44)

    I am indeed running the v5.28.2 verions of Perl. Should I do something different to recompile XML::Parser?

      Try cpanm -U XML::Parser. That'll prompt you to remove the distribution. After that's done, try reinstalling as normal.

        When I run the uninstall, I get:

        Successfully uninstalled XML::Parser

        But when I try to install again, I get

        XML::Parser is up to date. (2.44)

        This happens whether I user cpan or cpanm

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://11104115]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others having an uproarious good time at the Monastery: (5)
As of 2019-10-24 04:14 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Notices?