Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Re: Cannot install UUID Module

by pryrt (Prior)
on Dec 16, 2019 at 14:26 UTC ( #11110247=note: print w/replies, xml ) Need Help??


in reply to Cannot install UUID Module

The CPAN Testers report says UUID-0.28 can successfully install on Win 10, Strawberry Perl v5.30.1; unfortunately, I don't know why they didn't have problems with the library when you did

Do you absolutely need UUID? Or could you use Data::UUID instead? That one installed for me with 5.30.0 with no problem (though you might need to create c:\tmp)

I decided to see whether UUID worked for me, using the cpanm client to --look inside the distribution to manually do the build, test, and install steps separately. I didn't install any separate libraries before running this. I included my perl -V, in case that will help you. I did not have any problems; maybe this will give some hints as to what's different.

update

Wait, re-reading your error messages, # Compiler seems to be C:\MinGW\bin\gcc.exe. That's not normal if you're using Strawberry perl. Before trying to use the toolchain to build non-pure-perl modules, it's best to make sure that all the strawberry paths are before any other compilers in your path. If you were using portable strawberry, you could just run portableperl.bat portableshell.bat. Otherwise, run PATH=c:\strawberry\c\bin;c:\strawberry\perl\bin;c:\strawberry\perl\site\bin;%PATH% before trying to install using cpanm UUID.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://11110247]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chilling in the Monastery: (8)
As of 2020-05-29 11:15 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    If programming languages were movie genres, Perl would be:















    Results (169 votes). Check out past polls.

    Notices?