Beefy Boxes and Bandwidth Generously Provided by pair Networks
Syntactic Confectionery Delight
 
PerlMonks  

Re^2: PPM missing in ActiveState 5.28 trying to install IMage::Magick

by marto (Archbishop)
on Feb 21, 2020 at 16:06 UTC ( #11113316=note: print w/replies, xml ) Need Help??


in reply to Re: PPM missing in ActiveState 5.28 trying to install IMage::Magick
in thread PPM missing in ActiveState 5.28 trying to install IMage::Magick

Use cpan/cpanm, better yet just use Strawberry Perl and make life easy on yourself.

  • Comment on Re^2: PPM missing in ActiveState 5.28 trying to install IMage::Magick

Replies are listed 'Best First'.
Re^3: PPM missing in ActiveState 5.28 trying to install IMage::Magick
by RedJeep (Sexton) on Feb 21, 2020 at 17:23 UTC
    That almost worked. Ran cpan install Image::Magick but failed on dmake. Looks like dmake is not included in ActiveState ActivePerl 5.26 and 5.28. Either ActiveState totally kluged up Perl or they failed to communicate effectively how to install modules or I just don't know how to follow the good advice provided here along with an inability to read docs. Looks like I am going to attempt switch to Strawberry Perl. Thanks again for the help everyone!
      Looks like I am going to attempt switch to Strawberry Perl

      I think that's a step in a better direction.
      However, it's not a panacea, and you might still face some challenges in getting Image::Magick installed.
      Strawberry Perl does not provide the prerequisite C libraries for Image::Magick, so you'll still need to source those and then make them accessible to the Image::Magick build process if you want to build Image::Magick yourself.

      Of course, as mentioned elsewhere in this thread, Strawberry Perl does ship with a PPM utility, so you could still "ppm install" Image::Magick from the sisyphusion.tk repo if need be (and thereby avoid the need to track down that "prerequisite C library").

      Cheers,
      Rob
        Waah waah waah :D
        $ ppm install Gtk3 Gtk3 Installing package 'Gtk3'... Error installing package 'Gtk3': Error reading http://www.sisyphusion. +tk/ppm/x86/Gtk3-516.tar.gz Installing package 'Gtk3'... Error installing package 'Gtk3': Could not locate a PPD file for packa +ge Gtk3

        This went ok but it made no improvements to install Gtk3 timing out slowly at different points

        ppm install Crypt-SSLeay Net-SSLeay Mozilla::CA IO::Socket::SSL

      ActiveState does not ship with a c compiler or build tools, you need to install them yourself or via ppm MinGW, which brings us back to the whole ppm issue. Save yourself a lot of time and potential headache, just install Strawberry, which does ship with a sane development environment of of the box.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://11113316]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others drinking their drinks and smoking their pipes about the Monastery: (6)
As of 2020-05-31 07:46 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    If programming languages were movie genres, Perl would be:















    Results (173 votes). Check out past polls.

    Notices?