Beefy Boxes and Bandwidth Generously Provided by pair Networks
go ahead... be a heretic
 
PerlMonks  

Re^6: PPM missing in ActiveState 5.28 trying to install IMage::Magick

by syphilis (Bishop)
on Feb 23, 2020 at 07:08 UTC ( #11113339=note: print w/replies, xml ) Need Help??


in reply to Re^5: PPM missing in ActiveState 5.28 trying to install IMage::Magick
in thread PPM missing in ActiveState 5.28 trying to install IMage::Magick

$ ppm install Gtk3 Gtk3

Does it make any difference if you instead run ppm install Gtk3
Are you running this in a bash shell ? I've never used ppm in anything other than the cmd.exe shell, but I'm not sure, off the top of my head, whether that should matter.
Also, what does perl -V output ?

I downloaded http://www.sisyphusion.tk/ppm/x86/Gtk3-516.tar.gz and it unpacked fine for me.
Also grabbed http://www.sisyphusion.tk/ppm/Gtk3.ppd which seems ok, too.

Cheers,
Rob

Replies are listed 'Best First'.
Re^7: PPM missing in ActiveState 5.28 trying to install IMage::Magick
by Anonymous Monk on Feb 24, 2020 at 02:36 UTC
    ppm install Gtk3 makes no difference, only the error message is usually about Gtk3-516.tar.gz, after really really long delay

    I'm using cmd.exe

    oh, PPM.log sometimes complains

    ppm.bat: read_href: Error reading http://www.sisyphusion.tk/ppm/Glib-O +bject-Introspection.ppd: 500 Can't connect to www.sisyphusion.tk:80 ( +A connection attempt failed because the connected party did not prope +rly respond after a period of time, or established connection failed +because connected host has failed to respond.) at Sun Feb 23 17:54:30 + 2020

    Summary of my perl5 (revision 5 version 16 subversion 1) configuration +: Platform: osname=MSWin32, osvers=6.0, archname=MSWin32-x86-multi-thread uname='' config_args='undef' hint=recommended, useposix=true, d_sigaction=undef useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=und +ef use64bitint=undef, use64bitall=undef, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='gcc', ccflags =' -s -O2 -DWIN32 -DPERL_RELOCATABLE_INCPUSH -D +PERL_TEXTMODE_SCRIPTS -DUSE_SITECUSTOMIZE -DPERL_IMPLICIT_CONTEXT -DP +ERL_IMPLICIT_SYS -fno-strict-aliasing -mms-bitfields -D_USE_32BIT_TIM +E_T', optimize='-s -O2', cppflags='-DWIN32' ccversion='', gccversion='4.6.3', gccosandvers='' intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234 d_longlong=undef, longlongsize=8, d_longdbl=define, longdblsize=12 ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='long lo +ng', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='g++', ldflags ='-D_USE_32BIT_TIME_T -s -L"D:\perl\lib\CORE" -L +"D:\perl\mingw\mingw32\i686-w64-mingw32\lib"' libpth=D:\perl\mingw\mingw32\i686-w64-mingw32\lib libs=-lmoldname -lkernel32 -luser32 -lgdi32 -lwinspool -lcomdlg32 +-ladvapi32 -lshell32 -lole32 -loleaut32 -lnetapi32 -luuid -lws2_32 -l +mpr -lwinmm -lversion -lodbc32 -lodbccp32 -lcomctl32 perllibs=-lmoldname -lkernel32 -luser32 -lgdi32 -lwinspool -lcomdl +g32 -ladvapi32 -lshell32 -lole32 -loleaut32 -lnetapi32 -luuid -lws2_3 +2 -lmpr -lwinmm -lversion -lodbc32 -lodbccp32 -lcomctl32 libc=, so=dll, useshrplib=true, libperl=libperl516.a gnulibc_version='' Dynamic Linking: dlsrc=dl_win32.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' ' cccdlflags=' ', lddlflags='-mdll -D_USE_32BIT_TIME_T -s -L"D:\perl +\lib\CORE" -L"D:\perl\mingw\mingw32\i686-w64-mingw32\lib"' Characteristics of this binary (from libperl): Compile-time options: HAS_TIMES HAVE_INTERP_INTERN MULTIPLICITY PERLIO_LAYERS PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT PERL_IMPLICIT_SYS PERL_MALLOC_WRAP PERL_PRESERVE_IVUV PERL_RELOCATABLE_INCPUSH PL_OP_SLAB_ALLOC USE_ITHREADS USE_LARGE_FILES USE_LOCALE USE_LOCALE_COLLATE USE_LOCALE_CTYPE USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF USE_SITECUSTOMIZE Built under MSWin32 Compiled at Oct 14 2012 15:01:37 %ENV: PERL_MB_OPT=" --config installhtmldir= --binhtml= " @INC: D:/perl/site/lib/MSWin32-x86-multi-thread D:/perl/site/lib D:/perl/vendor/lib D:/perl/lib .

    $ ppm version 11.11_04
      .... after really really long delay

      This sounds similar to the difficulty that I currently have in accessing many of the files at sisyphusion.tk (and lots of other places on the internet) via http.
      I'm assuming that the problem with the sisyphusion.tk files that I can't get (eg http://www.sisyphusion.tk/ppmindex.html) is the same as the problem with other files that I can't get (eg http://strawberryperl.com/releases.html).
      But maybe there's some different issues at play there.
      Can you successfully browse to either of those 2 links ?

      According to the sisyphusion.tk raw access logs, when I try to browse to ppmindex.html, sisyphusion.tk server receives the request and replies with the usual 200 response, but that response never gats back to me. Every 30 seconds the browser sends off another request, with exactly the same result. After the 10th request has been sent, the browser just gives up and times out.

      I grabbed the raw access logs for what might be your attempts to ppm install Gtk3, and I've stuck 'em on my scratchpad. There's a couple of 416 errors in relation to requests from Mozilla. The "bytes" number is wrong - which, I guess, explains the "416". And there's a couple of 404's and some 3xx redirects (again resulting from requests from Mozilla) but, AFAICT, the requests from D:\perl\citrusperl\site\bin\ppm.bat\0.1 are all being successfully met, except for a legitimate 404 for GET /ppm/file:Image-Magick.ppd.ppd
      However, maybe that's not you ... if you want to send me your IP address I can take another look.

      Cheers,
      Rob

        Can you successfully browse to either of those 2 links ?

        Yup

        However, maybe that's not you ... are all being successfully met

        It is me, weird ... but I've also used curl successfully to download some files ...

        But maybe there's some different issues at play there.

        I've installed Image-Magick successfully

        I hope its not bugs in LWP, i'd like to fix those

        curl mostly works for downloading from you

        but ppm is spazzing on reading local .ppd files

        I hope I'm the only one with this issue ... could be bad ram :/

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://11113339]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others scrutinizing the Monastery: (8)
As of 2020-06-01 17:25 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Do you really want to know if there is extraterrestrial life?



    Results (5 votes). Check out past polls.

    Notices?