http://www.perlmonks.org?node_id=11114023


in reply to Re^4: use Email::Valid offline
in thread use Email::Valid offline

I am having problems updating to the latest which is 1.21. Need to understand why.

That's probably a good place to spend some effort. The latest, which is actually v1.22 (as of Feb 13, 2020), shows no win32 errors, neither does v1.21.

Are you trying to install with network disabled? Because the Net::DNS test suite implies that it requires a network connection during testing. If you want it to not run networking tests, https://metacpan.org/source/NLNETLABS/Net-DNS-1.22/README says to run with --no-online-tests option: though it said the online-test portion of the suite "will not adversely affect the outcome of test suite", so not sure why it would stop the installation. If you need help debugging that upgrade problem, post the details of the failed test and/or installation.

looking again at test reports, v1.20 does show some win32 errors, such as mswin perl v5.24.0. I don't know enough to know whether the error shown is a network-related error, or whether it's the same as the error you are getting.