Beefy Boxes and Bandwidth Generously Provided by pair Networks
Do you know where your variables are?
 
PerlMonks  

*.exe from pp on Win7 fails

by aplonis (Pilgrim)
on Jun 07, 2017 at 23:26 UTC ( #1192308=perlquestion: print w/replies, xml ) Need Help??

aplonis has asked for the wisdom of the Perl Monks concerning the following question:

So I have a script (nothing fancy, no GUI, just a file-parser) that runs fine under Strawberry Perl in it's pure *.pl form. I use...

pp -o foo.exe foo.pl

...to make an *.exe, and it does that with no complaint. But if I click on the *.exe, then a DOS window pops up (as expected) but shows no text to indicate progress, but simply blinks into non-existence after a second or two.

How do I troubleshoot something like that? Using the verbose tag on pp was not informative so far as I could e..

Replies are listed 'Best First'.
Re: *.exe from pp on Win7 fails ( ppsimple.pl )
by Anonymous Monk on Jun 07, 2017 at 23:36 UTC

    Give ppsimple.pl a try, if it doesn't work post the last part of the log which is the call to pp/invocation of pp, and the output of pp

      Yes, ppsimple.pl proved helpful. It revealed my problem to be an absence of the module Proc::Background in my system, which apparently pp needs but the *.pl didn't.

      Indeed, excellent! I had to force-install that one, then install a few others, until ... at last ... ppsimple.pl ran out of errors to report and just followed through to make my now-working *.exe so thanks heaps!

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1192308]
Approved by Paladin
Front-paged by Corion
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others meditating upon the Monastery: (9)
As of 2019-07-19 12:11 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?