http://www.perlmonks.org?node_id=1194236


in reply to Install Module with no admin permission

The --shelltype option was introduced with local::lib 2.0.

I guess a quick workaround could be to use a more bourne sh-compatible shell instead of csh.

The somewhat longer approach would be to install a more recent local::lib, potentially from within that bourne shell.