Beefy Boxes and Bandwidth Generously Provided by pair Networks
Welcome to the Monastery
 
PerlMonks  

Re: Explicit Package?

by toolic (Bishop)
on Feb 07, 2019 at 19:39 UTC ( #1229561=note: print w/replies, xml ) Need Help??


in reply to Explicit Package?

use v5.14;
That line loads the strict pragma, the same as if you had:
use strict;
Refer to use VERSION:
Similarly, if the specified Perl version is greater than or equal to 5.12.0, strictures are enabled lexically as with use strict
That is the reason for your error messages. You need to declare your variables with my and open your file handles before using them.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1229561]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others taking refuge in the Monastery: (5)
As of 2020-10-21 13:29 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    My favourite web site is:












    Results (217 votes). Check out past polls.

    Notices?