Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

comment on

( #3333=superdoc: print w/replies, xml ) Need Help??
Did you compile them yourself? Or are they precompiled binaries? From what your original error suggests, you are having trouble with libpng.

You are not the first person that has had this problem, including myself. What always works, is to get the latest GD c lib from boutell.com and compile it yourself, after reading the docs on how to include png and gif support. Then make sure you get no errors, and don't have 2 gd libs installed with 2 different header files. You may have headers and libs in /usr /usr/local and /usr/X11R6. These will conflict, so make sure you have only one. The same is true for libpng and libgif and/or libungif. Make sure you have only one, and only it's matching header file in the various include directories. Then once you have libgd properly installed, install the Perl GD module, and watch for errors.

The reason this all comes about, is usually your "linux distribution" puts these in different places, depending on how they like to do things. BUT when you get source tarballs, they will usually default to putting things in /usr/local, without checking for other versions....so you can end up with dual libraries, and multiple header files. Then depending on how your search paths are setup, you may get 1 header file assigned to a wrong library version, or some other glitch.

Also, I can't say for sure whether you using Perl version 5.61 is causing some problem. The GD people always go with the "current releases" and seem to care little about insuring backward compatibility. You can read the Changelog for the module to see what libgd version it requires.

Also from vague memory, their was some changes in libpng awhile ago, so maybe you need to reinstall the latest libpng first, BEFORE building libgd. There are alot of details to getting GD installed properly. You can groups.google search for "GD png" and maybe get some tips.

Also, if you are stuck using Perl561, maybe ask around for people who still have this version, and what level libgd they use, and which older Perl GD module is compatible with it.


I'm not really a human, but I play one on earth. flash japh

In reply to Re^5: Problem executing GD module by zentara
in thread Problem executing GD module by bar10der

Title:
Use:  <p> text here (a paragraph) </p>
and:  <code> code here </code>
to format your post; it's "PerlMonks-approved HTML":



  • Are you posting in the right place? Check out Where do I post X? to know for sure.
  • Posts may use any of the Perl Monks Approved HTML tags. Currently these include the following:
    <code> <a> <b> <big> <blockquote> <br /> <dd> <dl> <dt> <em> <font> <h1> <h2> <h3> <h4> <h5> <h6> <hr /> <i> <li> <nbsp> <ol> <p> <small> <strike> <strong> <sub> <sup> <table> <td> <th> <tr> <tt> <u> <ul>
  • Snippets of code should be wrapped in <code> tags not <pre> tags. In fact, <pre> tags should generally be avoided. If they must be used, extreme care should be taken to ensure that their contents do not have long lines (<70 chars), in order to prevent horizontal scrolling (and possible janitor intervention).
  • Want more info? How to link or or How to display code and escape characters are good places to start.
Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others taking refuge in the Monastery: (3)
As of 2021-12-03 01:04 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    R or B?



    Results (27 votes). Check out past polls.

    Notices?