Beefy Boxes and Bandwidth Generously Provided by pair Networks
Syntactic Confectionery Delight
 
PerlMonks  

Problem installing PAR

by willyyam (Priest)
on Mar 30, 2005 at 14:34 UTC ( #443467=perlquestion: print w/replies, xml ) Need Help??

willyyam has asked for the wisdom of the Perl Monks concerning the following question:

I've been Google-ing this one, but I'm not finding anything that seems to help. A similar problem has occured with the compliation of of programs, but I find no reference to this with regard to Perl modules. It appears to be a linker error in the testing of the PAR module. Here's the last bit of output:

: undefined reference to `Perl_sv_2pv_flags' collect2: ld returned 1 exit status make[1]: *** [par] Error 1 make[1]: Leaving directory `/$HOME/.cpan/build/PAR-0.87/myldr' make: *** [subdirs] Error 2 /usr/bin/make -- NOT OK Running make test Can't test without successful make Running make install make had returned bad status, install seems impossible

Any help would be appreciated. Thanks.

More info: This is being done on an up-to-date linux machine . I get the same result with both cpan -i PAR and CPAN>install PAR. This has usually been sufficient for other module installations, but I am happy to take other suggestions.

Replies are listed 'Best First'.
Re: Problem installing PAR
by starbolin (Hermit) on Mar 30, 2005 at 18:21 UTC

    You don't mention what you've tried other than google. The documentation refers to specific modules and versions required. Do you have these?

    They also have a mail list with lots of archives. This guy seems to have a similar problem. Seems like your Perl binary has to be built with the same version libc as that which you are now linking against.

    s//----->\t/;$~="JAPH";s//\r<$~~/;{s|~$~-|-~$~|||s |-$~~|$~~-|||s,<$~~,<~$~,,s,~$~>,$~~>,, $|=1,select$,,$,,$,,1e-1;print;redo}
Re: Problem installing PAR
by sunadmn (Curate) on Mar 30, 2005 at 16:55 UTC
    I have had the same issue with the most current version also, of course I was using active state Perl on windows so I just found another compiled version on the net and the install went fine. Since you are using cpan to install you could just use the force flag to install eventhough you fail the test. This is not the correct answer I know to the issue, but it will get the module installed. Also on a side note you may want to find out what version of ExtUtils is installed it may incompatible with the PM ( not sure on that one but have seen it in the past ).
    SUNADMN
    USE PERL
      sunadmn,
      Since you are using cpan to install you could just use the force flag to install eventhough you fail the test. This is not the correct answer I know to the issue, but it will get the module installed.

      No it won't. The error isn't concerning a failing test, it is failing to compile at all. I don't have any answer but this isn't it.

      Perhaps checking the PAR FAQ or visiting the PAR Homepage might help shed some light on the matter.

      Cheers - L~R

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://443467]
Approved by Corion
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others avoiding work at the Monastery: (4)
As of 2019-12-16 00:52 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?