Beefy Boxes and Bandwidth Generously Provided by pair Networks
XP is just a number
 
PerlMonks  

Re^3: cpan try to install a module for a higher perl revision

by trwww (Priest)
on Dec 16, 2009 at 21:13 UTC ( #813084=note: print w/replies, xml ) Need Help??


in reply to Re^2: cpan try to install a module for a higher perl revision
in thread cpan try to install a module for a higher perl revision

There are non way to configure cpan in order to limit it's search only to module revision suitable to my perl revision ?

No, unfortunately there is not. I'm sure patches are welcome :0)

The first thing I would try would be to download the package, modify the part of the dist that forces this requirement, and see if the tests still pass. If they do, I'd say you are safe to use it.

Next would be as others have suggested, to find a version of the dist that does install successfully with your version of perl.

If you can't get a version of the module working with your perl and you really need this module, you'll have to build a newer perl. See Re: 2nd Perl installation on Mac OSX

But matter what, you're going to have to learn how the module system works if you need this module. You're using a really old operating system, so you're not going to get much support. But rest assured there are still relatively simple ways to get it to do what you need.

  • Comment on Re^3: cpan try to install a module for a higher perl revision

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://813084]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (4)
As of 2019-03-26 20:28 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    How do you Carpe diem?





    Results (125 votes). Check out past polls.

    Notices?