http://www.perlmonks.org?node_id=918604


in reply to Re^4: What's the deal with ExtUtils::MakeMaker [build_requires]
in thread What's the deal with ExtUtils::MakeMaker [build_requires]

I don't run 'follow' as my prereq policy. I have never seen this issue. Including in a test I'm running right now.

You are doing something weird somewhere in you config, that you've managed to replicate out. I have no idea what, but that is not normal behavior.

Edit: It's possible that some module you are using has done an exceptionally bad job of specifying it's requirements, and managed to confuse perl into thinking it wants a newer version of that module, despite it already having the newest version. I'm not exactly sure what type of bug would cause that, but I can see something along that line happening with the mess that is the various different ways to specify version strings in Perl.