Beefy Boxes and Bandwidth Generously Provided by pair Networks
laziness, impatience, and hubris
 
PerlMonks  

Re^6: LWP Can't POST to HTTPS

by Anonymous Monk
on Sep 12, 2012 at 17:56 UTC ( #993272=note: print w/replies, xml ) Need Help??


in reply to Re^5: LWP Can't POST to HTTPS
in thread LWP Can't POST to HTTPS

From Long delay with Crypt::SSLeay and LWP, the thing you linked and read and tried a "solution" from, the diagnostic steps

#!/usr/bin/perl -- use LWP::Simple ; use IO::Socket::SSL qw(debug3); get( q{https://pilot-payflowpro.paypal.com/} ); get( q{https://xxxx.ucf.edu} ); __END__

Replies are listed 'Best First'.
Re^7: LWP Can't POST to HTTPS
by dorko (Prior) on Sep 12, 2012 at 18:42 UTC
    Mea maxima culpa. I'm sorry, when I said "looking at" I should have said "skimmed". Admittedly, I didn't read that. Thank you.

    This is the results of IO::Socket::SSL qw(debug3); for the POST.

    DEBUG: .../IO/Socket/SSL.pm:1645: new ctx 32651216 DEBUG: .../IO/Socket/SSL.pm:363: socket not yet connected DEBUG: .../IO/Socket/SSL.pm:365: socket connected DEBUG: .../IO/Socket/SSL.pm:383: ssl handshake not started DEBUG: .../IO/Socket/SSL.pm:446: Net::SSLeay::connect -> -1 DEBUG: .../IO/Socket/SSL.pm:1320: SSL connect attempt failed with unkn +own error error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/SSL.pm:452: fatal SSL error: SSL connect attempt +failed with unknown error error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/SSL.pm:1320: IO::Socket::INET configuration faile +d error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/SSL.pm:1682: free ctx 32651216 open=32651216 DEBUG: .../IO/Socket/SSL.pm:1690: OK free ctx 32651216
    Again, any help will be appreciated. Thanks for your time.

    Cheers,

    Brent

    -- Yeah, I'm a Delt.

      Looks to me like you edited that. I get

      DEBUG: .../IO/Socket/SSL.pm:354: ssl handshake not started DEBUG: .../IO/Socket/SSL.pm:1555: ok=1 cert=18003144 DEBUG: .../IO/Socket/SSL.pm:1555: ok=1 cert=18832752 DEBUG: .../IO/Socket/SSL.pm:1555: ok=1 cert=18830608 DEBUG: .../IO/Socket/SSL.pm:1555: ok=1 cert=18829200 DEBUG: .../IO/Socket/SSL.pm:1170: scheme=www cert=18829200 DEBUG: .../IO/Socket/SSL.pm:1177: identity=webcourses.ucf.edu cn=webco +urses.ucf.edu alt=2 webcourses.ucf.edu DEBUG: .../IO/Socket/SSL.pm:414: Net::SSLeay::connect -> 1

      Sure I'm using an older version of IO::Socket::SSL ( 1.58 ) compiled against older version of OpenSSL , but I doubt that makes a difference

        I can't think of a reason why I would edit my response.

        It seems to me the main difference between your output and mine is that your output looks like it worked, and mine failed. After all, I'm asking for help because it doesn't work.

        Thanks again for your time.

        Cheers,

        Brent

        -- Yeah, I'm a Delt.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://993272]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others examining the Monastery: (4)
As of 2021-03-03 15:12 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    My favorite kind of desktop background is:











    Results (80 votes). Check out past polls.

    Notices?