http://www.perlmonks.org?node_id=11105375

Hello! Here is my JAPH. Not very cryptic, I just want to say it:
#!/usr/bin/env perl use 5.026.1; no strict; format = . BEGIN { use SelfLoader; open *q, v60 , $0; s(.*)((<q>)[-1])e; open DATA, '<', \s( \S+ (?{ \&{$&} }) )( sub $& { \@_ = ( $& => \@_ ) and !wantarray ? formline<<~"\@_" : \@_ \@_, \@_ })rgx } END { write or die } Just another Perl hacker,

Replies are listed 'Best First'.
Re: Just another JAPH
by k-mx (Scribe) on Sep 14, 2019 at 07:28 UTC
    No END at the end.
    #!/usr/bin/env perl use 5.026.1; no strict; format = . BEGIN { use SelfLoader; open *q, v60 , $0; s(.*)((<q>)[-1])e; open DATA, '<', \s( \S+ (?{ \&{$&} }) )( sub $& { \@_ = ( $& => \@_ ) and !wantarray ? formline<<~"\@_" : \@_, write && () \@_, \@_ })rgx } Just another Perl hacker,
Re: Just another JAPH
by FreeBeerReekingMonk (Deacon) on Sep 14, 2019 at 21:55 UTC
    Aww, will take me a while to get that version of Perl on my system... (5.20 on Debian, 5.16 on RH)
      That's why I love perlbrew:
      perlbrew list perl-5.30.0 perl-5.28.2 perl-5.28.1 perl-5.24.1
      You can try this version:
      #!/usr/bin/env perl format = . BEGIN { use SelfLoader; open *q, v60 , $0; s(.*)((<q>)[-1])e; open DATA, '<', \s( \S+ (?{ \&{$&} }) )( sub $& { \@_ = ( $& => \@_ ) and !wantarray ? formline<<"\@_" : \@_, write && () \@_, \@_ })rgx } Just another Perl hacker,
      Without 5.26.0 related feature