Beefy Boxes and Bandwidth Generously Provided by pair Networks
"be consistent"
 
PerlMonks  

Re: wxPerl: Wx::DatePickerCtrl working, Wx::TimePickerCtrl failing? (bug)

by Anonymous Monk
on Apr 24, 2013 at 07:49 UTC ( #1030296=note: print w/replies, xml ) Need Help??

Help for this page

Select Code to Download


  1. or download this
    $ perl -MWx=:allclasses -le " print Wx::TimePickerCtrl->new "
    Wx::TimePickerCtrl=HASH(0x3fa184)
    
    $ perl -MWx -le " print join q/ /, $Wx::VERSION, Wx::wxVERSION_STRING 
    +"
    0.9918 wxWidgets 2.8.12
    
  2. or download this
    $ perl -MWx=:allclasses -le " print Wx::TimePickerCtrl->new( (undef) x
    + 33 ) "
    Usage: Wx::Window::newFull(CLASS, parent, id = wxID_ANY, pos = wxDefau
    +ltPosition, size = wxDefaultSize, style = 0, name = wxPanelNameStr) a
    +t -e line 1.
    
  3. or download this
    perl\vendor\lib\Wx\Calendar.pm
    33:package Wx::TimePickerCtrl;  @ISA = qw(Wx::Control);
    

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1030296]
help
Chatterbox?
[Corion]: Hmm - I would say the 5.8.5 is a broken installation / corrupt tarball download, and the 5.10.0 is really weird, and maybe a bug in that version of Perl
[Corion]: I don't see how my $result = eval q{'abc' =~ ?b?}; could create a "Modification of read-only value" error
[marto]: Discipulus the issue that should be adressed is that the page needs to be updated to reflect modern perl on Windows
[Discipulus]: but is really necessary to support these ancient versions? from 5.14 onward is not enough?
[Discipulus]: yes marto I understood
[Corion]: Discipulus: I'm slowly migrating my code to require 5.8.x ;) Most of my code works on 5.6, but Filter::signatures requires 5.10 I think
[Corion]: 5.14 is also a good target, widely available and fairly stable. Also, over five years old, which doesn't push people into a needless upgrade cycle
[Discipulus]: yes I saw your efforts Corion but the pain is worth?
[Corion]: Discipulus: IMO it's not that much pain, but most of the systems I use have a Perl 5.14 or newer on them nowadays

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (10)
As of 2018-06-25 08:47 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Should cpanminus be part of the standard Perl release?



    Results (126 votes). Check out past polls.

    Notices?